Alpha mask not applied

I’m evaluating Artlantis (2021 with Big Sur), I like it very much! I have a problem, I have a number of .fbx files that I’d like to import. The objects in this file have various maps like albedo, normal etc. applied. One of the maps is an opacity map. When I import the .fbx, Artlantis loads the maps but doesn’t seem to apply the opacity map as per the screen shot. You can see the source opacity map in the screenshot as well. I tried to create a texture manually, when I choose an opacity map, it loads in the dialog but is not applied to the shader. What am I doing wrong?



Good to hear you like Artlantis very much !

To use the opacity mask, if it is an image with alpha channel, just check « use alpha channel » in the dialog.
If it is just a black and white image, check the check box to the right of the « use alpha channel » and set the color in the color box to black.

It should work, if not, let me know.

Best regards,

Thanks, I don’t know what I did incorrectly last time when I created a shader but this time it worked. Linking everything back up would be pretty tedious but at least I can see how I’d do it. I have an additional question:

When I create a shader, it asks that I save the result and makes a .atls file. These files would be common among my models but I don’t see a way I can load them and attach them to an object. Is there a way I can do that?

If you save the atls+jpg in your Media library, you can use it in all the objects you want by Drag&Dropping it from the media catalog.

best regards,

I actually read the help documentation yesterday and saw that’s how it worked. Should do that first hey! Thank you for the reply to a lazy user! Some feedback, for my proposed workflow, it would be really helpful to be able to select the .atls file from the shader list - so choose the shader, right click, attach shader or something like that rather than finding an object that uses the shader. That way I can work my way down the list quickly. I guess once I’ve converted my models to atlo I’m done though… not an ongoing thing so probably an edge case.