Artlantis 6.5 soft shadows

Hello, Abvent!

Could you please tell me how to obtain soft sun shadows? I can’t do this anymore in Artlantis 6. They’re all sharp even with clouds option on and even if I pull the sun shadow bar to the left.

Thank you!

Good question. Even with sun power almost off, all clouds at maximum setting, pollution at maximum setting, the shadows are sharp and clear. They should barely be noticeable. Turning up sky power doesn’t help - sky power seems to only control the brightness of the sky; the sky does not seem to contribute to the lighting of the scene. Sun shadows seem to be independent of all other settings.

This sure is an annoying bug. Let’s hope Abvent will give us an answer.

The answer from today’s live webinar is to use HDRI - which does work, but completely takes away all the advantages of using the physical sky, accurate and adjustable date and time, etc. It is surprising that the physical sky does not consider anything but the sun. I would think that at least the sky light would contribute to the lighting, as it does in reality.

I spent some time trying to achieve soft shadows by adding a light plane, and then by adding actual lights. This will lighten the shadow, but not soften it. And turning down the sun power to compensate for the additional light darkens the sky.

I think there is clearly a need to enable diffuse sunlight and the resulting soft shadows.

There is also a need to allow the sky to provide indirect illumination to the scene. The sky is, in the real world, a major factor in exterior lighting, and should be a factor in the rendering. I ended my experiments by rendering a simple scene with only normal sunlight, and then with sunlight supplemented by a large, overhead plane on which I used the neon shader to simulate indirect sky light. The renders are attached. The addition of the secondary light contributes significantly to the image (The first image is with the light plane, the second without).

They know everything! Will fix in next release! :mrgreen: