Noisy background

Hello you all
I´m having problems with the grass shader. I share my setting and the example. I don´t know how to fix it. Anyone can help please?
I don´t like the grass, is too noisy. I tested with many different grasses, always the same.

Did you try increasing the size of the grass shader ?

Hello Camille
I´ve also tried increseasing 2 and 4 times the size. But I don´t see a substantial difference.
What do you think?

Pasto 5afuera.jpg
pasto 5.jpg

Hello again,

Are you using HDRI lighting ?
Because that might cause the problem.
If you use HDRI, you need to use Exposure 1, check Enhanced background, set light sampling to 5 and check Automatic white balance.
Hopefully this should help removing the noisy effect on the grass shader :sunglasses:

This is what I’ve done for this image:


Hello Camille
It´s not better. I tried the same settings as you recommended me, and similar setting without HDR.

this image was missing, is the one your recommended me


With the recommended setting the grass is a little less noisy. I’m not sure we can make it better… sorry
I can ask Stephane Desmulie when he comes back from vacation next week.

But the image is too bright, maybe change the lighting power of your HDR.

Best regards,

Ok, perhaps she has any idea. Please, let me know. Thanks and


Stephane told be the noise might come from the bump value of the grass shader. Have you added some bump on the grass shader ?

Best regards,

There´s no bump added. But It seems the images looks better, what do you think? I attach them with the Camille advice settings, and another with similar settings

I think they look nice :wink: