Page 1 of 1

Texture on 3d People

Posted: Fri 5 Apr 2019 11:08
by kgriffith
I am still having issues with missing textures on some of the 3d figures. Is there a way to avoid or correct this?
People.PNG
People.PNG (156.59 KiB) Viewed 4923 times

Re: Texture on 3d People

Posted: Fri 5 Apr 2019 12:34
by CamilleSarrut
Hello,

Are those 3D people from the Standard Media library ?
From the Store ?
Which Artlantis version are you using ?

Re: Texture on 3d People

Posted: Fri 5 Apr 2019 15:55
by kgriffith
I believe they are from the store - when I log into the store they show as 'downloaded'.

This image is from Artlantis 2019, but I was getting the same in Artlantis 7.

Re: Texture on 3d People

Posted: Fri 5 Apr 2019 16:05
by CamilleSarrut
Hi,

I reproduced the issue, I have asked the person in charge of the Media to have a look at it.

Re: Texture on 3d People

Posted: Fri 5 Apr 2019 16:39
by CamilleSarrut
In fact I found out what the problem is, both objects texture are using a "Transparency color" set to black.
If you uncheck the transparency color the hair will be visible again.
It seems we make more colors transparent than the set color, in this case the pure black, we will check for this issue.
But in the meantime you can use this workaround.

with_black_transparent.png
with_black_transparent.png (432.62 KiB) Viewed 4914 times


without_black_transparent.png
without_black_transparent.png (422.98 KiB) Viewed 4914 times

Re: Texture on 3d People

Posted: Mon 8 Apr 2019 11:01
by kgriffith
OK, thanks - that definitely helps. But I notice that I have a different shader menu than you show, so I can't uncheck transparency. The best I can do is to change the transparency color from black to white...
Shader Menu.PNG
Shader Menu.PNG (33.91 KiB) Viewed 4908 times

Re: Texture on 3d People

Posted: Tue 9 Apr 2019 08:30
by CamilleSarrut
kgriffith wrote:OK, thanks - that definitely helps. But I notice that I have a different shader menu than you show, so I can't uncheck transparency. The best I can do is to change the transparency color from black to white

You have to select the texture in the material list, to have the texture inspector with the transparent color checkbox.

This is the inspector when the shader is selected in the list:
shader_selected.png
shader_selected.png (97.99 KiB) Viewed 4903 times


this is the inspector when the texture is selected in the list:
texture_selected.png
texture_selected.png (117.39 KiB) Viewed 4903 times

Re: Texture on 3d People

Posted: Tue 9 Apr 2019 11:04
by kgriffith
Got it. Thanks again!