EdHaynes
Posts: 10
Joined: Tue 7 Mar 2017 18:55

Imbed Video into Animation

Thu 5 Nov 2020 23:54

Is there a way to imbed video playback in an animation? I need to show a moving video wall and would like the image on the screen to move.as well.

User avatar
CamilleSarrut
Posts: 751
Joined: Tue 20 Oct 2015 08:41

Re: Imbed Video into Animation

Fri 6 Nov 2020 08:55

Hello Ed,

Yes, it is possible.
First activate the Animation inspector and select the Animation sequence in which you want to see the movie.
Then Drag&Drop a movie file, mp4 for exemple, onto your wall, resize the texture to fit the part of the wall where you want the movie to be shown.
Hit the play button in the timeline window, you should see the movie played on the wall.

I have attached a small animation with a television displaying a movie.

Best regards,
Attachments
animation_3spots+texture_animee_1client_pas de bug texture anime.mp4.zip
(377.85 KiB) Downloaded 42 times
Camille Sarrut
Abvent R&D

Johnstock81
Posts: 2
Joined: Sun 13 Dec 2020 10:44

Re: Imbed Video into Animation

Wed 6 Jan 2021 10:05

Hi

Just tried imbed of .mp4 video into a tv screen for an animation walk through. It plays in preview viewport and when i change frame number but when i render it out, the screen remains with a static image?? Any ideas?

Process so far:
Select animation sequence
Drag n drop texture .mp4 onto screen
Resize texture to screen
Played in animation to check it plays video
Render out .mp4 animation but in animation walk through, screen image remains static??@!! :roll:

Any help / advice appreciated.

User avatar
CamilleSarrut
Posts: 751
Joined: Tue 20 Oct 2015 08:41

Re: Imbed Video into Animation

Thu 7 Jan 2021 18:31

Johnstock81 wrote:Hi

Just tried imbed of .mp4 video into a tv screen for an animation walk through. It plays in preview viewport and when i change frame number but when i render it out, the screen remains with a static image?? Any ideas?

Process so far:
Select animation sequence
Drag n drop texture .mp4 onto screen
Resize texture to screen
Played in animation to check it plays video
Render out .mp4 animation but in animation walk through, screen image remains static??@!! :roll:

Any help / advice appreciated.


Hello,

We found out this issue with MP4 is on Windows only.
If you use AVI video on Windows it works fine.
We should fix this issue in the next update of Artlantis.

Unfortunately AVI is not supported by macOS, so you will not be able to render an AVI texture on macOS...

On which platform/OS are you trying to render ?
In Artlantis, Batch or Render Manager ?
Which version of Artlantis ?
Camille Sarrut
Abvent R&D

Return to “Animation”